Technical Support Forum

1.WooDang Man » Thu Oct 08, 2015 5:55 am

Welcome to the Technical Support section of the Age of Wushu Dynasty forum. In this section, you can submit technical problems you've encountered with Age of Wushu Dynasty, as well as review fellow player's with similar problems and find solutions from our support team.

Contacting Support

As an important note - the primary contact for all technical support is
SupportUSA@snailgame.net. If a problem has not been resolved previously on the Forum, players should contact Support directly to get assistance with their problem.

Posting

When posting your tech support issue, be sure to include the following info as much as possible:

    -Your IGN and Server (do not include your account or login info!)
    -Your device specifications - model, brand, OS, etc.
    -Your connection type - Wifi, data plan with name of provider
    -Your location globally

Also, whenever possible, please include a screenshot of the problem for reference. Pictures can be included in a post by uploading a document directly, or by using basic BBCode tags from a photo sharing site like Imgur.


Duplicate Posts

Be sure to check this Forum for similar problems before posting yours, as the issue may already be resolved and duplicate posts will be subject to merging or deletion if no longer relevant.
Quote
Age of Wushu: Facebook | Website

Image

SupportUSA@snailgame.net

2.Syntax » Tue Nov 24, 2015 5:45 pm

Hello, i just want to report that the apk of v1.4 wouldnt installed it said app not installed ive already download it 10x but i didnt succeed... one more thing isnt there a autopatch on the game so i woudnt download a new version of apk? i will attach the screen shot
IGN:Syntax
Server: Us-Closed Beta
Phone: Cherry Mobile Omega Icon
Os: Android Jeallybean 4.3
Network: Globe
Connection: Mobile Data
Country: Philippines
Attachments

Screenshot_2015-11-25-01-29-14.png
This is the new version apk 1.4
Screenshot_2015-11-25-01-29-14.png (57.67 KiB) Viewed 19902 times

Quote

3.Buddha Heart Palm » Tue Dec 01, 2015 5:19 am

Syntax wrote:Hello, i just want to report that the apk of v1.4 wouldnt installed it said app not installed ive already download it 10x but i didnt succeed... one more thing isnt there a autopatch on the game so i woudnt download a new version of apk? i will attach the screen shot
IGN:Syntax
Server: Us-Closed Beta
Phone: Cherry Mobile Omega Icon
Os: Android Jeallybean 4.3
Network: Globe
Connection: Mobile Data
Country: Philippines



Greetings,

Dear Player. Thanks for contacting. Sorry for the inconvenience but we will report this issue to our related team, we will reply you again once we get update on this issue. Thanks for your support.

Best Regards,
AOWD Team
Quote
Age of Wushu Dynasty: Facebook | Website
SupportUSA@snailgame.net

4.LittleThree asia » Sat Jan 09, 2016 1:51 pm

Pls kindly assist.

Asia server, character name "LittleThree"
Game crashed, purchases and character all gone. Why? How? What to do?

Pls show some compassion and assist. Thank u so much
Quote

5.107664536409713219291 » Tue Jan 12, 2016 7:44 pm

Hi! When AoW Dynasty will be released in Ukranian Google Play?
Quote

6.Beslan » Wed Jan 13, 2016 3:28 pm

I can not enter the game because I do not have servers

Image
Quote

7.vryonism@otenet.gr » Sun Apr 24, 2016 6:15 am

Dear Snail team,
I'm terribly sorry for the inconvenience of my post, but I don't have a Skype account and my email has been hacked. So, my problem is, whenever I try to load the game after the new version, it says "Updated" and is "Connecting...", but crashes afterwards. I'm using an iPad 3, iOS 9.3.1 and regular Wi-Fi as my type of connection. I live in Athens, Greece.
Quote
A great body is temporary, although important. A good soul lasts forever.
IGN: ShiWuLong
SERVER: EU2-Ruined Valley

9.lollipop » Sun Jul 10, 2016 1:55 pm

Image



could any one who can help me with that issue?? i tried to purchase a gold using my load balance.

i visit the link that they given to me they requires banking statement or credit/debit card which is i don't have any of them..

does any one encounter this problem?? can you help me thank you and more power
Quote

10.crazygames304@gmail.com » Thu Jun 22, 2017 5:38 pm

Hi i has a problem when i loggin in the create character screen is bugged the in game bugged like there is no models everyhere is white square pls help
Quote
Sort by

« Technical Support

cron