1.1438356826261058 » Tue Aug 08, 2017 3:56 pm

Hello. I've been playing AOWD since 2016. Stopped and returned this year. My old character has top up history on it and I've been trying to top up for my new character(new server) but everytime I clicked the 'Top up' button on the shop, the pay pop-up(the Google payment pop-up) does not appear. But instead simply 'ERROR:' shows up. I tried reinstalling the App, updating my payment method at Google but still same error appear. Please help me on this. Thanks.

Here's a screenshot of the error.
Screenshot_2017-08-08-22-31-30-754_com.snailgameusa.aowd.jpg (88.5 KiB) Viewed 1829 times


2.Jack123 » Wed Aug 09, 2017 2:17 am


Dear player, thank you for contacting. As to the image you've attached, we recommend you follow the setting on your device and verify your account(the account of the device which used for top-up through Google play store) first. Please have a try. If there's any other questions, please feel free to contact us.

Thank you for your support and have a nice day.
Best regards,
AOWD Support Team

3.1438356826261058 » Wed Aug 09, 2017 1:48 pm

Hello. Thanks for the reply. Please take note that I'm using the same account I used the first time I topped-up successfully(connected with Facebook). I tried re-logging it in and out then in. Still, the error occurs. I tried using another account using my Google account(just to test) but the same error appears. Is there any other way to fix this? Thanks in advance.

4.HeroineLX » Thu Aug 10, 2017 12:09 pm


Dear player. May I ask can you top up now? If you still could not top up, please send an e-mail to us to We will help you as soon as possible.

Thank you for your support, have a good time.

Best regards,
AOWD support team
Sort by

« Technical Support